Jump to content
Lara Croft Online Tomb Raider Forum

Stuck In Lost City

Recommended Posts

I have completed the story and now going to try for 100%. I'm at 97% and trying to finish up The Lost City. I found the last relic, up on top of the tower. I had to shoot climbing arrows and then climb up to a platform and found the relic on the right side of the platform. Now I can't get down and I can't seem to get to the base camp at the Final Precipice.

From where I am, I jump to an ice wall, climb up and then around to an opening. Use the grapple to jump across a gap. Then use a grapple to jump to a pillar and climb around and up the pillar. Then use more climbing arrows to move around two walls and on to a platform. Leap across the platform using a pole and here's where I'm stuck.

Basically, I'm stuck at 1:58 in this video: 


I can't seem to make this jump. I did it before when I completed the game, but now I just can't seem to get across. I'm trying to get to the Final Precipice base camp so I can continue the game. Unless there is a way down from platform with the relic? I have tried, I can climb down the wall, but can't reach the wall where the climbing arrow would be, and certainly wouldn't be able to shoot one hanging on to the wall.

I also can't seem to get in to the Square Enix forums, I have an account but the forum won't let me log in - I can log in to my SE account and change things, but the forum doesn't work. Is it because I'm in the US?

Anyway, thanks for the help!

Share this post

Link to post
Share on other sites

I can get in there just fine and I'm from the US. I would contact the admin. there and let them know.

Driber on the forum there sorts all that stuff out.

Stella completed the game and she usually helps here. If not I'll look into my game guide. I've been busy and haven't

had time to finish it yet.

Share this post

Link to post
Share on other sites

I figured it out. I was doing my jump wrong. It's the farthest swing like that in the game, as far as I can recall and I seemed to have tried to use my axe too early.


Share this post

Link to post
Share on other sites

That's similar to the old school games where you had to take two steps back and jump just at the right time to grab to a distant ledge or something.

Glad you didn't give up and sorted it out!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now